Fog Creek Software
Discussion Board




Problems with Access database connection

I am having problems using FogBugz with a Microsoft Access database (see error message below).  I've followed the advice on the web-site and checked the permissions on the TEMP drive but this hasn't solved the problem.  Does anyone have any suggestions?

Thanks,

Steve

-----------------

The FogBUGZ database is down or could not be found.

For security reasons, this cannot be fixed over the web.

Please edit the registry on the FogBUGZ server. The setting you want is HKEY_LOCAL_MACHINE\SOFTWARE\Fog Creek Software\FogBUGZ\D:/Program Files/FogBUGZ Development/website\sConnectionString.

To use SQL Server, set this to Provider=sqloledb;Data Source=server;Initial Catalog=database;Integrated Security=SSPI;

To use Access, set this to Provider=Microsoft.Jet.OLEDB.4.0;Data Source=filename

Or, you can always use an ODBC data source name, which you establish using the Data Sources (ODBC) control panel.

Stephen Cady
Friday, March 21, 2003

Note that you have to restart the server once this happens.  Also if you are upgrading from 2.0 you may also have to go into Internet Services Manager, click properties on the fogbugz virtual directory, click the directory security tab, hit the edit button on the top right, hit the edit on the top right again, and set this user to 'FogBUGZ', uncheck the control password box and enter the correct password.

Also to get to the exact MDAC error message, you can open preheader.asp and toward the bottom of the file it says

Else ' Not fDemo
  On Error Resume Next
....
  On Error Goto 0

Comment out the On Error Resume Next line so it looks like

Else ' Not fDemo
  ' On Error Resume Next

This will allow the actual error message to propogate up.

Michael H. Pryor
Friday, March 21, 2003

*  Recent Topics

*  Fog Creek Home