Fog Creek Software
Discussion Board




MySQL installation woes

so we're trying to install FogBugz using a MySQL backend.  We've made a database in mysql, but that's about it.

first, which dsn do we use?  user, system, or file?  is fogbugz a user that sits over a local database, and then serves files, so it should be a user dsn?  or is it connecting users to a database, acting as a gobetween?  which of these do I choose?

second, assuming I have that problem fixed, there's a magic sConnection string in the registry.  I've tried both User and File DSN connections (probably set up wrong), with the following permutations in the sConnection string:
fogbugz
FogBUGZ
Provider=FogBUGZ
Provider=fogbugz
Provider=FogBUGZ;filename=e:\local\file\name
and none of those seem to work.  what should I be doing here for this kind of connection?

third, what's the deal with passwords?  where do I start using those?  yes, yes, if I have a tinfoil hat on, everything should be passworded with obscure serial numbers and Czech phrases spelled backwards, but seriously, what will people in the outside world see?  The database, the odbc connection, or just fogbugz?  The server will sit behind a firewall with a VPN for remote users to access it. 


I (obviously) have absolutely no database backend experience whatsoever, so any help would be greatly appreciated. 

Thanks
Mark

Mark Roden
Wednesday, March 05, 2003

If you create a System DSN, it will be available globally on the system, so that's what you want.

Then the connection string is just the name of your DSN; we recommend FogBUGZ.

If you don't want to bother with DSNs at all, you can create a complete connection string that encapsulates all the info FogBUGZ needs to get to your database.

For a local mySQL database, the format is:

Driver={mySQL};Server=mySrvName;Option=16834;Database=mydatabase;

For a remote database:

Driver={mySQL};Server=data.domain.com;Port=3306;Option=131072;Stmt=;Database=my-database;Uid=username;Pwd=password;

I copied these things from www.connectionstrings.com and actually have no idea if they work :) In the morning when Michael wakes up he can tell me if this is right and improve the documentation...

You can get away without using passwords if your server is firewalled and not available on the public Internet AND you trust people not to log on as other people and muck about.

If your server is reachable from the public Internet, passwords are a must.

Joel Spolsky
Wednesday, March 05, 2003

Use the System DSN (myODBC driver) and make sure you check off the checkboxes that the article talks about in the tech support article.  The connection strings won't work because you need those special boxes checked off.  But everything else Joel said is right on...

Michael H. Pryor
Wednesday, March 05, 2003

thanks, we're up and running!

May I suggest including this knowledge in the 'using mysql' article?  I notice that the DSN stuff is there, but the sConnection string knowledge would also be a good addition.

but thanks again!  so nice to have a working bug tracking database....

Mark Roden
Thursday, March 06, 2003

I purposefully left the sConnection string info out, because it doesn't work.  The way described in the article is the only way to get it to work.

Michael H. Pryor
Thursday, March 06, 2003

I have just installed ForBUGZ and I am trying to switch it from using Access/Jet to using MySQL.  I have run the script to move the fogbugz database into MySQL (and that appears to have worked).  However, I am having troubles changing my site configuration  to use MySQL

I have defined a System DSN:
  Name: FogBUGZ
  Driver: MySQL ODBC 3.51 driver
  Server Name: localhost
  Database Name: fogbugz
  User: ****...
  Password: ****...
  Port: 3306
  SQL command on connect:

The "Test Data Source" button works.

However, when I change the database from Access/Jet to and ODBC source named "fogbugz" on the site configuration screen, and hit submit, it hangs forever (well, at least overnight).

If I then kill my browser and bring it up again.  Nothing has changed.

Any ideas?

Dave Clements
Wednesday, August 20, 2003

The problem reported in my previous post has been resolved.  Somewhere in the installation (I can't find it now, but I know it is there) it tells you to turn off Script Blocking in Norton Antivrus.  I did this, and made a careful note to myself to turn it back on when installation was complete.  Which I did.

This was a no-no and is what caused my problems.  Yo need to leave script blocking off in order for FogBUGZ to run.

Dave Clements
Thursday, August 28, 2003

*  Recent Topics

*  Fog Creek Home