Fog Creek Software
Discussion Board




Emails with Attachments -- Bug? Strange Behavior!

We have been getting the following behavior when sending emails containing email attachments to our fogbugz server email address:

FogBugz opens a sequence of cases, all named identically, but with consecutive case numbers.  In the worst of the occurrances to date an email was sent with a 2.8M Word Doc attached.  Fogbugz created 34 new cases all containing the same email and all having the same document available as a hyperlink.  I check the first and last instance of the 34 cases created.  They appear identical.  The email had been sent only once.

What to do?  Our customer support and product testing group is now relying on the system and this issue (bug?) is generating dozens of redundant cases.

Assad E.K. Ebrahim
Monday, December 23, 2002

Is the case still sitting in the POP3 mailbox?  Is it the case that every time the Dispatcho service checks for emails, it finds one, and creates a new case, but fails to delete the message from the POP3 mailbox, so when it checks again, the message is still there (and it repeats the cycle).

Does this only happen with large attachments?  What about a 10k attachment for example?

Michael H. Pryor
Monday, December 23, 2002

We get this on our copy of fb as well. Every now and then a bug that had been sent to the fogbugz email address appears twice (never had more than 2 copies). This happens about once is every 20 or so inquiries that come in. I have not noticed any correlation between this problem and attachments though.
By the time we notice there is a duplicate, the email message has been removed from the pop3 mailbox, but it does seem as if the bug is caused by dispatcho leaving the message without deleting it occasionally.

Of course it could be the mail server failing to delete things that it should be, as most mail clients are smart enough to spot duplicates and handle it. Maybe fogbugz should check that it has not already got an identical email message already.

Rik
Tuesday, December 24, 2002

This could have something to do with how the bug attachment was submitted.  Outlook Express (and other email clients) has a feature that will automatically break up messages greater than a certain size (look at the Advanced tab of the account settings).
I'm guessing that what is happening is that you are getting the multiple, broken up messages each creating a case.
Maybe Dispatcho needs to be updated to handle multi-part messages by attaching them together as one before it is submitted to the bug engine.

Karan Mavai
Friday, December 27, 2002

Karan,

Like you said, this is a function of the mail *client*, and in this case, we are the mail client and we don't break apart the messages.  I think it's a timeout issue (the bug goes in, but the page times out before it can send the OK to dispatcho telling it the bug was received, so the email doesn't get deleted).

Dispatcho handles multipart messages fine, and we've been using this feature for the past four or five months and have never seen this (and we've tested it with very large attachments).  So it should be a configuration issue, not a code issue.

Michael H. Pryor
Friday, December 27, 2002

Great, I'm happy to hear.  I just threw it out there as I wasn't sure.  Your explanation makes sense.

Karan Mavai
Friday, December 27, 2002

*  Recent Topics

*  Fog Creek Home