Fog Creek Software
Discussion Board




Knowledge Base
Documentation
Terry's Tips
Darren's Tips

Urgent bug in 2.0

We have a character in all of our pages in the header that looks kind of like this:

>>

Its Ascii 187. In CD 1.0 it works fine. I installed CD 2.0, upgraded an published. The character appears fine in the editor but it publishes as:

¦#187

This is making our site look really bad. You can see an example page it published at:
http://www.atozed.com/indy/Book/

Chad Hower
Sunday, September 07, 2003

Just paste a » directly into the editor and it will publish fine.

Joel Spolsky
Sunday, September 07, 2003

(or put a » into the HTML view)

Joel Spolsky
Sunday, September 07, 2003

"Just paste a » directly into the editor and it will publish fine."

No it doesnt. Thats exactly what we HAVE in there now and what is not working.

Chad Hower
Monday, September 08, 2003

"(or put a » into the HTML view)"

Does not work either, CD converts it to the actual character after changing to preview, and then back to HTML its the actually character again, but at publish time its #187

Take a look at the URL I posted and you can see.

Chad Hower
Monday, September 08, 2003

Chad :re ""(or put a » into the HTML view)"

create a var and for its value type in »

Place the var in your template or whatever {$.var$}

That should accomplish what you're after.

David Mozer
Monday, September 08, 2003

Ill try that as a hack. But this will require me to edit HUNDREDS of pages.

Surely this can just be FIXED no?

Chad Z. Hower
Tuesday, September 09, 2003

Chad, if your stuff is Template driven and you place the {$.var$} in that Template -- the Template does all the work under CD .... Why would you have too edit HUNDREDS of pages?

In my sites [which are all Intranets] I have between 3 and 8 Templates generating anywhere from 70 to 400 pages. And by using variables ... changes are very easy to implement regardless of how many pages there may be.

I use CSS within CD on my all my Templates  and am very pleased with the way it currently works. I do not use CSS within the CD Article editor because THAT article editor is designed *mostly* for end-users and I do believe that the KISS principal is at work --- the HTML view is to facilitate developers and perhaps one day Joel and the fog creek gang will incorporate better CSS integration isolating that aspect from the end-user via access permissions -- I never would imagine end-users wanting to use HTML view or being bothered with CSS rules. The Normal View has a very good WYSIWYG editor and THAT is what the end-user wants … Yes the WYSIWYG editor could use more Style options and that may come with time.

David Mozer
Tuesday, September 09, 2003

Once the ">>" variable is implemented there's no longer any manual work.  The problem, I guess, is that Mr. Hower will have to edit 100s of pages to include the variable and remove the unwanted syntax.

What I would like to see is a global find and replace option.  In fact, one where you could select which folder or folders to execute a find and replace.  Now wouldn't THAT be sweet!

George Illes
Tuesday, September 09, 2003

...maybe with access...

Robert Cappa
Tuesday, September 09, 2003

Because its part of the breadcrumbs, which are NOT in the template.

I understand CD 2 has another way to do bread crumbs, btu we already have an established method, and Im not going to edit HUNDREDS of pages because CD 2 has a new bug.

Chad Z. Hower
Wednesday, September 10, 2003

Its actually publishing it as:
В&#187

in the HTML. :(

Chad Z. Hower
Wednesday, September 10, 2003

This may be silly to ask, but do you have
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />

in the head section of your document?

Joel Goldstick
Wednesday, September 10, 2003

I checked your webpage and see that you do.  hmmmm

Joel Goldstick
Wednesday, September 10, 2003

Hi Chad,

looking at your site I noticed a few things:
First there's a strange character before your >>.
Second, looking at the source I noticed there's a ; missing after the 187. I see &#187&nbsp; in your source, rather than &#187;&nbsp;
Maybe the most interesting: If I look at your page with IE set to use UTF-8 as specified, I see |#187 (hope this turns out okay after posting), but when I change the encoding to Western European(ISO) it shows a capital A with a ^, then your >> character.

So apart from the missing ; there might be some unicode/encoding problem. According to the 'What's new' article, "CityDesk is now completely Unicode capable". So maybe your pages are now published in a different encoding, which conflicts with your web server.

Just when I wanted to try on my personal site the FTP died. I might try later. If I manage I'll post again.

Duq
Thursday, September 11, 2003

After the FTP was back up I tried the following:
I went to your page, and copied part of the source (the line that contains >>). Pasted this into an empty article, replaced the links by # and published. ( http://home.zonnet.nl/Duq_13/Articles/Testing187.html )
Then went to my own site. First strange thing: even thoug the source starts with <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" /> IE defaults to ISO encoding. But even after forcing it to UTF-8 it still shows the >> character. Then looked at the source, and it's actually different from what I thought I'd published!

There must be more to this. I checked http://czyborra.com/utf/#UTF-8 a great site about anything unicode. Guess what the UTF-8 sequence is for HTML &#187;? You guessed it: »

So as I said earlier, I suspect a little mistranslation between CD and your webserver.
Hope all this makes sense and/or helps....

Duq
Thursday, September 11, 2003

It seems that CD 2.0 is not encoding the character, where I think CD 1.0 did.

This used to work fine in CD 1 - upgraded to CD 2, and only now is it breaking this.

All of our pages are processed by an ISAPI filter. I've verified that it is not causing this behaviour, but in the interest of time we are just going to modify it to translate it on the fly.

Chad Z. Hower
Friday, September 12, 2003

*  Recent Topics

*  Fog Creek Home