Fog Creek Software
Discussion Board




Knowledge Base
Documentation
Terry's Tips
Darren's Tips

Normal View cursor navigation issue

Hi,

I only use normal vie when I am writing an article that needs a fixed format of html tags (eg. pre with tons of code etc).

So in normal view I saw this behavior today which seems like a bug. I start from the beginning of the html file and use the cursor keys to move down towards the end or across lines. I hit enter and make edits in the HTML always being careful to write correct XHTML. So I reach a paragraph tag that should be a <pre> tag and I edit it. While on my way to the matching </p> tag I notice that the cursor navigation has gone crazy. The down arrow won't move the cursor down. The right arrow key makes the cursor go to random places in the HTML.

I try to click in the window with the mouse to place the cursor where I need it but it does'nt want to go there. So now I have a <pre> tag with no matching </pre> tag because I havent been able to get to the </p> to make it into  a </pre> tag.

If I switch to normal view CD is going to fix my unmatched <pre> tag. But with what?

I dont want that! Help!

I'm guessing its a bug with the normal view syntax highlighting code that watches what you type and colors it.

Anybody else seeing this?

Rahul

Rahul Singh
Monday, September 01, 2003

I haven't seen it, and I can't quite reproduce that behavior here, but it is very definitely a possible bug (I just don't know what).

If you can come up with reliable steps that cause this to happen every time, I'll be forever in your debt, and, even better, I'll fix it :)

Joel

Joel Spolsky
Tuesday, September 02, 2003

Its happened to me more than once (but not too often).  Its either my machine or its one of those bugs that comes up very rarely.

I'll keep a lookout for it and let you know if I can reproduce it reliably.

Meanwhile, CD is great. Thanks,

Rahul
http://www.kingtiny.net/

Rahul Singh
Tuesday, September 09, 2003

Editing certainly isn't like it used to be in V1.  I often find that Ctrt-enter won't add a br.  I do this nearly every day:

1. Ctrl-C, Ctrtl-V in the main window to copy a template" article
2. Edit the new (copy) article body to delete every thing but this HTML:
<p><br />
<a href="PTMFOG0000000960"><em>back to letters index</em></a></p>

3. Wash an email through notepad and paste it into the article.

Problem  A: Often before I paste in the new text, I like to add a few Crtl-Enter things above my link - nothing happens. Once I paste in the text, Ctrl-Enter works.

Problem B: Last night in the process, I realized the neither Ctrl-Enter, or just plain enter worked at all. I closed CityDesk, opened it again and was back in buisiness.

Last night might have been a fluke but problem A is chronic. I do it every day.

tk
Wednesday, September 10, 2003

*  Recent Topics

*  Fog Creek Home