Fog Creek Software
Discussion Board




Knowledge Base
Documentation
Terry's Tips
Darren's Tips

Possible bug in beta 2.0.7

I opened an existing CD site in 2.0.7 and hit preview. The dialog gave me about a jillion errors to do with "the variable x.headline is not defined". I figured, it must be a problem with a template, with this many files giving me grief, and it was. My template had magically changed from saying {$ .headline $} to saying {$ x.headline $}. None of the other variables in the template changed, just headline. Very weird. I changed it back, and everything works fine now. I renamed the backup that CD 2.0.7 made, opened it in CD 2.0.7 to see if it happened again, let it convert, and it didn't! What the hey?

Israel Orange
Sunday, July 27, 2003

I see people have been having other bugs with .headline...I wonder if this is somehow related?

Israel Orange
Sunday, July 27, 2003

I forgot to mention something-my variable got [[]] bracketed around it too, in funny places. This is what it looked like before I fixed it:
<p><strong>[[</strong>{$x.headline$}]]</p>
Of course, being a local reference to the headline, I had no need for it to be a link. It never was supposed to be. Also, where did the spaces go inside the curly braces?
Sorry to have so many posts, I'm trying to describe what happened as accurately as possible.

Israel Orange
Sunday, July 27, 2003

This is my last addendum, I swear! This cty file: was created in CD 1.0 VIP, and worked fine there. I ran it through the 2.0.5 converter and immediately closed it; I just wanted to convert it. Then I opened it in 2.0.7 when I was actually ready to edit it. So perhaps this has already been fixed, as when I reopen the CD 1 backup file in CD 2.0.7, the problem does not recur? I no longer have 2.0.5 to test this.

Israel Orange
Sunday, July 27, 2003

*  Recent Topics

*  Fog Creek Home