Fog Creek Software
Discussion Board




Knowledge Base
Documentation
Terry's Tips
Darren's Tips

Closing Tags On Next Line

This may be related to the bug noted in:
http://discuss.fogcreek.com/CityDesk/default.asp?cmd=show&ixPost=7968&ixReplies=2

I find closing tags moved to the next line a bit annoying. It may be a HTML standard (??) but I intentionally set my opening and closing tags inline - it's the way I like it.
<li>This is a list item.</li>

If I go in to HTML View and do it manually it's OK until I switch to and from Normal View - then I do it again.

Dave
Tuesday, July 15, 2003

Does this happen anywhere other than </li>'s ?

Joel Spolsky
Tuesday, July 15, 2003

No it doesn't. 
Sorry Joel I should have checked before making a blanket statement like that. As far as I can tell it only happens for <li>'s.

Dave
Tuesday, July 15, 2003

Grrr, proof before send, proof before send...

It only happens for </li>'s.

Dave
Tuesday, July 15, 2003

Yeah, it's actually a super hard bug for us to fix. Basically the underlying IE control removes the </li> since it doesn't seem to like them; we put them back later using TidyLib, but TidyLib doesn't know where the original </li> was and can't put it back in the same place. For us to fix this is going to involve a lot of special-case code just for </li>, which we may do, but I'd like to be sure that this is the only place we need this.

Joel Spolsky
Wednesday, July 16, 2003

Joel, thanx for the 'why' - going gold or adding additional new features sounds like a great use of your time. I'll get over it, but then I suspect you knew I would :)

Dave
Wednesday, July 16, 2003

*  Recent Topics

*  Fog Creek Home