Fog Creek Software
Discussion Board




Knowledge Base
Documentation
Terry's Tips
Darren's Tips

Non-breaking spaces

I've noticed recently that CD seems to insert non-breaking spaces arbitrarily in text.

When I write my turgid prose, I tend to copy-and-paste quite a bit, moving sentences around, etc., in the editor. When I switch over to html, I notice the special characters.

I haven't tracked it enough to discern a pattern or a cause for the effect. If nothing else, something for Joel to put on the list.

Amos
Thursday, March 06, 2003

When in doubt CD inserts a non-breaking space – just to be on the safe side. Or if you have put in two or more spaces and afterwards deletes all but one, CD will keep the non-breaking one. I think this is OK. Only if your are very concerned over line breaks you should open the file in html and replace the   with ordinary spaces. If this is a bug, it's a very small one – you have to be fair to Mr Spolsky some times

Jorgen Brenting
Thursday, March 06, 2003

Thanks, Jorgen. No intent to bust Joel's chops on this.

Amos
Thursday, March 06, 2003

There's another post somewhere in the past where Joel gives the reasoning behind the current   behavior.

David Burch
Thursday, March 06, 2003

It's because if you type space space, we insert one regular space and one   to preserve your intention to have two spaces. Then if you happen to delete the regular space, you're left with a  . It all seems like correct behavior when you think about it although it does sometimes make word wrapping weird.

Joel Spolsky
Friday, March 07, 2003

This non-breaking-space issue is the main reason I stopped editing my articles in "Normal" view.  Seriously, it messes-up the layout a lot, when you have non-breaking spaces everywhere.  I'm a little surprised that this was intentional.

In the next release of CityDesk, I'd suggest having an option to turn off this behavior.  Then, I'd go back to using "Normal" view.

Alex Chernavsky
Saturday, March 08, 2003

I second the request to be able to turn off the use of non-breaking spaces in CD. The odd wrapping behavior they create causes a problem for me in each new article that I create.

I now use the find replace feature to replace all   instances with a single space before I publish the article. This reduces the issue to a small annoyance since the replace runs through the article pretty quickly.

I have been pounding on CityDesk for about one week now and this is the only problem that I have encountered. Bravo and thanks for saving me from my old web authoring tools.

Bryan Hall
Wednesday, March 12, 2003

I just know that any time I hit space space one of them must be an   so I just delete the whole space and add it in again any time I go to edit something with multiple spaces. It's perfectly logical if you know HTML... somewhat less so if you don't.

www.marktaw.com
Wednesday, March 12, 2003

In many cases it makes perfect sense to have CD add non breaking spaces. I like it as it is.  If you could turn it on and of, it would be better though.

Jorgen Brenting
Thursday, March 13, 2003

What would hitting space multiple times do? And how would you add multiple spaces if you wanted them?

I guess shift+space could insert an   ... isn't this similar to how Dreamweaver behaves?

www.marktaw.com
Thursday, March 13, 2003

*  Recent Topics

*  Fog Creek Home