Fog Creek Software
Discussion Board




Knowledge Base
Documentation
Terry's Tips
Darren's Tips

Do Not Publish problem

I just realized that a couple of articles which I had marked as Do Not Publish in fact were published.

In this case, not that big a deal. However, a word of caution -- apparently this function is not foolproof. So, if you have articles that MUST NOT be published, I would suggest not depending on the Do Not Publish feature. At the very least, double check every time you publish.

Amos
Tuesday, February 11, 2003

Do you mean "Never Publish After" or do you mean "Audience" ? I'd love to hear more details.

www.marktaw.com
Tuesday, February 11, 2003

"Never Publish After". I had two articles in draft state and has selected Never Publish.

This morning when I published, the two articles along with links to them on an index page showed up. I was on the way out the door, so I ftp'd to my site from work and removed the link statements from the html directly. I left the article files on the server.

A little testing:

1. I just published (changed files) my site again, and the index links did not show up again. Apparently CD views everything as unchanged.
2. I deselected Never Publish from one of the articles and published. No reference on the index page, i.e. no new link created.
3. Changed the text in the article and published. Still no new link.
4. Publish all files. Both links appear on the index page, even though one of the files is still marked Never Publish.

Hope this helps.

Amos
Tuesday, February 11, 2003

When you say "deselected <blah> and republished", did you just publish that one article or the whole site? Just publishing the one article won't modify index pages etc - it just updates that one article.

Also, are you setting the date in "Never Publish After"? If you just tick the box, I don't think it will prevent the article from being published until *after* the date in the field (i.e. tomorrow, if it has today as the default value).

Don't forget to save the article after you modify the "Never Publish After" field, too. If you just tick or untick it and hit the Publish Site button in the main window, your changes won't have any effect. You have to save it first.

Perhaps if you give us a bit more detail on what you're doing, we can help a bit more.

Darren Collins
Wednesday, February 12, 2003

Publishing: now that's another issue! I find that publishing just one page, either to my local server or to my public server, doesn't work. So I always publish the entire site.

When I set the NPA, I always backtrack a couple of days to make sure that today is covered in the range of dates.

Yes, I comprehend that saving is required to complete a change, so yes, I saved all changes before publishing.

I'm not sure there is any help to be had, Darren, but thanks for the concern. I figured that this is a bug of some sort or another -- may have to do with Win2k SP3 for all I know. I haven't had the problem before. I assume that if there is anything to address, it will be addressed in ver 2 which is due out imminently (right, Joel?!?). I more wanted to post the warning so that others would make sure to double check.

Amos
Wednesday, February 12, 2003

Amos, I've had this problem with never publish after dates.  I don't exactly remember the circumstances but I usually preview when npa dates are an issue.  I've added one space to the text to the problem pages to insure CD publishes them.  This is very rare problem for me.

tk
Wednesday, February 12, 2003

*  Recent Topics

*  Fog Creek Home