Fog Creek Software
Discussion Board




Knowledge Base
Documentation
Terry's Tips
Darren's Tips

Publishing problem

I just bought Citidesk home edition version 1.0.31 and I have a problem in publishing my website. OS: Win 98SE.

I can preview it well, but when I want to publish it (ftp or file copy), there are no files copied to the destination directory.
The publishing process does not give me any error message except warnings about untranslated article.

Does anybody have any idea how to solve my problem?

sachli
Wednesday, December 18, 2002

Can you manually FTP to this site without a problem?

Try that first

John Cesta
Wednesday, December 18, 2002

Yes I can. I can FTP my site using internet browser and WSFTP.

Even when I published it on my local disk (file copy mode), the files are not created.

sachli
Thursday, December 19, 2002

I don't know if it can be considered as a bug.
As I mentioned, the only message I got was the warning on untranslated article.

After I translate all untranslated article, then... Ta Da...
the publishing process now has generated the files and copied them via FTP.

Strange right? But anyway, it solves my problem.

sachli
Thursday, December 19, 2002

The CityDesk documentation says:

"CityDesk assumes that every article in your site needs to be translated to every language. If you only translate a subset of your site, you should create a separate CityDesk site file for that subset. Otherwise, you will receive warnings about articles being untranslated."

(see http://www.fogcreek.com/CityDesk/help/Features/CreatingaMultilingualSite.html)

It doesn't explicitly state that your site won't get published if there are untranslated articles - perhaps someone from Fog Creek could make the documentation more clear?

Darren Collins
Thursday, December 19, 2002

Here is a related topic, "sparsely translated sites," with a statement from Joel:

http://discuss.fogcreek.com/CityDesk/default.asp?cmd=show&ixPost=3613&ixReplies=4

tk
Thursday, December 19, 2002

*  Recent Topics

*  Fog Creek Home