Fog Creek Software
Discussion Board




Knowledge Base
Documentation
Terry's Tips
Darren's Tips

Couldn't put file: The server returned extended in

Help.

I'm losing files on my webserver.  Not all of them, however. just a couple. Also, I can view and edit all my files locally, it's just that uploading is failing all of the sudden, and the failure erases the files on the server. May want to not over-write files on the server with a size 0 file if there's an error.

Earlier I managed to erase every single file on my webserver when IE's ftp setting somehow got changed and stopped supporting passive mode ftp. I switched passive mode back on, and now I'm only erasing a couple files. I'm not sure if I'm feeling brave enough to try uploading a couple more times to see if it straightens itself out. In any case, I'd like to see cd not blow away my files on the webserver when passive mode support gets turned off.

Also, I can't find much in the way of error codes, diagnostic information or log files, etc, so I don't have much to report. All I get is errors like:

FTP Error Uploading www/index.html -- Couldn't put file: The server returned extended information

I get one of these for each file that gets blown away. 

Another suggestion would be to have the errors show up in a friendlier box.  Errors show up in the publish dialog, which contains a text area that doesn't have scrollbars. So if you want to see all of the error info, you need to highlight off the upper or lower edge of the text area.

I'm running win2k with cd Starter Edition Version 1.0.31, Build Date: 20020808A. If there's any more information you need from me, please let me know.

Roman Zabicki
Tuesday, November 12, 2002

PS I know I should download and use 1.0.31 sp 2, instead of just plain old 1.0.31, but I didn't want to add another variable into the equation while I was trying to straighten this out.

Roman Zabicki
Tuesday, November 12, 2002

I think the answer to this problem was to delete the citydesk.xml from the server and republish.

Guy Bjerke
Wednesday, November 13, 2002

SP2 does a much better if not perfect job with FTP.  Your situation still happens to me once in a while.  Erasing the xml file is probably the trick.

tk
Wednesday, November 13, 2002

Thanks very much for your advice.

I uploaded again, and everything sorted itself out. But I will definitely upgrade, and if I ever get this problem again, I'll try deleting citydesk.xml on the server.

Roman Zabicki
Wednesday, November 13, 2002

*  Recent Topics

*  Fog Creek Home