Fog Creek Software
Discussion Board




Knowledge Base
Documentation
Terry's Tips
Darren's Tips

ftp bug connecting to Geocities

A month ago, publishing to my Geocities site was working correctly.  Recently, and consistently, if I have no open ftp session, and files to publish, Geocities will reject CityDesk's first attempt to log in.

CityDesk's error dialog has a "Try Again" button, and that one succeeds in publishing the site.

Does this happen for anyone else?  I think Geocities changed their ftp server, but it's CityDesk's bug, since my other ftp clients still work with Geocities' server.

David Blume
Tuesday, October 29, 2002

This is really old:

http://discuss.fogcreek.com/CityDesk/default.asp?cmd=show&ixPost=683&ixReplies=0

tk
Tuesday, October 29, 2002

Yes, Terry, that was old, and it was irrelevant.

I hate to repeat myself, but my citydesk.xml file has been there for months.  I've never deleted it.

http://www.daliblume.com/blog/citydesk.xml

This new Geocities incompatibility only started with my last two publishes.  This is new incompatible behaviour.  And it is consistently reproducible.  If anybody at FogCreek is interested in fixing the bug, I'll be happy to elaborate.

David Blume
Wednesday, October 30, 2002

we are interested!

Key question with all FTP problems: does it work right with the ftp client built into internet explorer?

Joel Spolsky
Wednesday, October 30, 2002

The bug did not occur today.  I followed my recipe exactly (simply dirtying one article and publishing) and was going to hand-copy GeoCities' exact "failure to login message..."

But "Publish" worked exactly as advertised once again.  I'm happy CityDesk is working again for me, but feel bad I can't provide more info on the bug that troubled my past two publishes.

If it happens again, (and I'm not counting on that) I'll copy the ftp log letter-for-letter.

David Blume
Thursday, October 31, 2002

Maybe Geocities had a burp.  I do a Tripod site, a pretty big one.  One day my CityDesk FTP went down the tubes and I panicked.  Later that day I get an email from Tripod acknowledging the problem and it's worked fine after that.

tk
Thursday, October 31, 2002

I suspect that the issue with Geocities is that they have written some custom code on their servers which is supposed to check that only paid users use FTP; the problem might actually be that they either had a bug in that code, or something bizarre like the user database was temporarily down or flaky and thus wasn't reporting you as a paid user and thus sometimes you're not allowed to ftp.

It's just a guess. We certainly have more problems with geocities than any other ISP, and if we have time, we'd like to make a custom geocities upload module that uses geocities' web interface to upload files rather than ftp.

Joel Spolsky
Thursday, October 31, 2002

Is it silly to follow up on a bug that no longer occurs?

I can rule out the "paid subscriber" check theory.  CityDesk's Failure to Publish dialog's Retry button worked!  Then dirtying an article and republishing reproduced the bug, and Retry worked again.  (And again, and so on.)

Also, the Send Fogcreek Feedback dialog indicated an error in sending when I tried to report the bug that way.  But when I tried to reproduce that bug recently, my test feedback went through!  (Whoops)  Perhaps the two bugs were related?

At the time, my other online programs weren't having any problems.  It was only CityDesk.

David Blume
Friday, November 01, 2002

*  Recent Topics

*  Fog Creek Home