Fog Creek Software
Discussion Board




Knowledge Base
Documentation
Terry's Tips
Darren's Tips

Control over background color?

I'm experimenting with CityDesk on Windows 2000, and
so far I like it very much! One annoyance, though: on my
PC, I used Display->Properties->Appearance to set my
default windows background color to a light shade of gray.

When I use CityDesk to compose an article, the result that
I get is that CityDesk embeds

style="BACKGROUND-COLOR: #c0c0c0"

as an attribute in each paragraph tag in my article.

Can I control this behavior? I would rather that
CityDesk did *not* do this. The color looks nice on my
personal PC, but I do not want this color for the web
pages that I am writing.

Bryan Pendleton
Friday, August 16, 2002

These may help.

http://discuss.fogcreek.com/CityDesk/default.asp?cmd=show&ixPost=558&ixReplies=1

http://discuss.fogcreek.com/CityDesk/default.asp?cmd=show&ixPost=2543&ixReplies=3

tk
Friday, August 16, 2002

I've tried here, also using Windows 2000, and I simply can't reproduce the behavior you're describing. No matter what I set my background color to, CityDesk doesn't add those styles for me.

What version of Internet Explorer do you have? (I've got 6.0)

Joel Spolsky
Friday, August 16, 2002

I'm on WinXP with IE6 and I've have this happen to me occassionally (I use a non-white background on my PC). I mentioned it ages ago but it magically went away. It probably happens now once every 15 articles I create (maybe less) and I've never been able to reliably reproduce it.

I know this is no help but just confirming that it does happen (I wondered if I were going mad at one point).

John C
Saturday, August 17, 2002

You may also want to try adjusting the colors in Internet Explorer's "Internet Options" dialog -- try turning on and off the "use Windows colors" checkbox

Joel Spolsky
Saturday, August 17, 2002

When composing an article: do you type in the text in Citydesk or do you use a copy/paste from MS-Word or so?

I have never seen Citydesk making up styles but I may use it in a different fashion. I know copying from word gives lots of garbage.

Adriaan van den Brand
Saturday, August 17, 2002

Like John C., I can't reliably make this happen every time. It happened on my first article, but that might have just been luck.

Joel, I'm using IE 6.0.2600. I got it by applying Service Pack 3 to Windows 2000, I think. Toggling the Use Windows Colors checkbox definitely seems to fix the problem for me.

Adriaan, I was typing directly into CityDesk, not copying and pasting. Thanks for the warning about pasting from Word.

Also, I notice this, for what it's worth: the CityDesk editor appears to start the next paragraph by inheriting the styles from the previous one. That is, when I place my cursor at the end of a para which has a "font" style and hit Enter, the new paragraph inherits the style of the previous one.

So, it seems that I can work around the unwanted styles  (if they ever happen again) by simply: (a) starting a new article, (b) typing the first paragraph, (c) switching to HTML view, (d) cleaning out the unwanted styles.

Many thanks to all for the quick responses; they were most helpful!

Bryan Pendleton
Tuesday, August 20, 2002

Yep, turning off the "use windows colors" option in IE seems to cure the problem. Nice one.

John C
Thursday, August 22, 2002

*  Recent Topics

*  Fog Creek Home