Fog Creek Software
Discussion Board




Knowledge Base
Documentation
Terry's Tips
Darren's Tips

Published by fogcreek

The discussion was here before, but now it prevents me from doing some things. I would like to use PHP, and in order to prevent link rot, I did by enabling PHP parsing of html files.  Now I get php errors:

Warning: Cannot send session cache limiter - headers already sent (output started at /usr/home/aas/www/html/diensten/metrieken/quantize.html:2)

Reason: the php script i use wants to write the HTML header; this is not possible anymore since Citydesk already wrote the$*(#&!#$*
<!-- Published by Fog Creek Software CityDesk HBLCKNAFSJEWDORN/CADB8105/138 -->

PLEASE have it configurable, at least for the professional edition which I am using.

Adriaan van den Brand
Tuesday, August 06, 2002

I am doing exactly the same (using PHP, parsed by CD), and never have run into that kind of problem. Of course, CD creates an almost empty HTML file first (with it's signature in there), but that is easily editable.

Michael Vesely
Tuesday, August 06, 2002

I have PHP running on .html files. Some scripts write headers (e.g. for cookies or location: statements). This is only possible if the server hasn't started spooling the file to the browser.

Adriaan van den Brand
Tuesday, August 06, 2002

I have looked it up: the server is not even allowed to send a space if you want to modify the header. So the file MUST start with
<?php ....
  and not
<!-- published by ...

Adriaan van den Brand
Tuesday, August 06, 2002

I had this problem but as my ISP wouldn't allow html files to be executed i changed the template's extension to .php instead of .html and used that instead. Note that citydesk won't put the <!-- published by ... bit at the top of the .php file and so won't screw up server execution.

John C
Tuesday, August 06, 2002

That's  right. However, I loose the ability to preview locally (essential for a review process). People have bookmarked some pages and search engines know them. I can redirect those server side, but still : it is an annoyancy.

I have no problem with a meta tag "generator", but with this tag I do have problems. I just didn't know that yet at the time of the previous discussion about the subject.

Adriaan van den Brand
Tuesday, August 06, 2002

Yes, quite. As a result I never use the preview functionality. I have a second publish location to my localhost so I can preview it that way. Not perfect but it works.

John C
Tuesday, August 06, 2002

Why not just run up an APACHE server on your local machine which supports PHP, then publish to a local host and you can preview WITH live PHP ???

Don
Monday, August 12, 2002

I can easily do that. In fact, I have even found a way to get by it, by patching citydesk.exe
(look for unicode <!-- Published by Fog Creek Software CityDesk\0
and -->\0
and replace them with
<?php //published fog Creek Software Citydesk
and
?>

Even though that works, I doubt it is the prefered way.........And setting up apache servers with php and stuff is not the easy preview I like in Citydesk!

Last but not least: changing extensions is a risk for link rottage (even though I can probably limit the damage in .htaccess on the server)

Adriaan van den Brand
Tuesday, August 13, 2002

*  Recent Topics

*  Fog Creek Home