Fog Creek Software
Discussion Board




Knowledge Base
Documentation
Terry's Tips
Darren's Tips

Opening files in the editor of your choice

All non-article files (such as .html, .jpg, .bmp, .whatever) can be opened from within CityDesk in whatever editor you choose.  Either right click on the file, or choose "File|Open Item".

I like to use FrontPage, so I usually right click my .html files (and templates) and open them in frontpage.  When I'm done editing them, I just hit save in FrontPage, and the file in CityDesk will be updated.

Hopefully people who like their WYSIWYG editor of choice realize that CityDesk augments programs like FrontPage, it doesn't necessarily replace them (although it can).  So if you like the cool features of Dreamweaver then by all means, use it to edit your CityDesk files!  Right click and choose, "Open with Dreamweaver".  It's that easy!

Michael Pryor
Tuesday, October 16, 2001

When I "open with" or "right click" my index.html file I don't have a Frontpage option.  I get "open" "open in normal view" "open in HTML view" and "open with windows default viewer" and that's all.  How do I tell CityDesk that I have FrontPage as well?

Terry Kearns
Tuesday, October 16, 2001

When you have an .html file on your Desktop and you right click on it, you probably can't open it with FrontPage either - can you?  You should get the same options in CityDesk that you get on the Desktop.  Let me know if this is not the case.

(Check under "Tools|Options" and select the "Configure Editors" tab in FRONTPAGE.  Make sure .html (not just .htm) is listed in there - if it isn't add it, and then try CityDesk again.)

Michael Pryor
Tuesday, October 16, 2001

In FrontPage Tools|Options has FrontPage as the editor for my HTML files.  I can't find my CityDesk index.html file in Win Explorer to try to open it. All I find is the ".CTY" file.

There must be something fundamental I don't know.

TK

Terry Kearns
Tuesday, October 16, 2001

When I said:
"When you have an .html file on your Desktop and you right click on it, you probably can't open it with FrontPage either - can you?"

I just meant any old .html file.

You are probably running on Win98 so you don't have an Open With list in explorer (what I'm calling the desktop).  But if FrontPage is your default editor for .html files, then just choose "Open with Windows Default Viewer" in CityDesk.  (Otherwise, whatever is your default viewer will open it, maybe IE, maybe Dreamweaver... it's up to you to set it).

Michael Pryor
Tuesday, October 16, 2001

Even in Win98, you should be able to right-click a file, while holding the "SHIFT" key. Select "Open With", then select your tool of choice...Make sure you click the checkbox that says "Always use this program to open these files". CityDesk should pick up the proper tool from this point on...

Jonathan Goodyear (aka angryCoder)
Tuesday, October 16, 2001

OK, I've got Win98

In Windows Explorer, I right click on an ".html" file select "edit" and I get the file in FrontPage just fine.  If I select open, I get the file in IE.

In CityDesk, I right click on my "index.html" file, select "open with default viewer" and the file opens in Internet Explorer.

I tried this for a template as well.  When I try to "edit with default windows viewer," absolutely nothing happens - No Internet Explorer, No FrontPage, No Nothing.

I'd really like to edit in FrontPage. Am I doing something wrong or am I out of luck?

Terry Kearns
Tuesday, October 16, 2001

You aren't out of luck, its just that no all files understand the "edit" verb.  All files do understand the "open" verb, so thats the one CityDesk uses.

If you want CityDesk to have FrontPage open your files, you have to get Windows to work such that when you choose "Open" for an .html file on the desktop, it opens in frontpage.

(the template should work the same then too, provided it has an .html extension -- sorry for the confusing "edit" language in the template editor -- its not the same as the "edit" verb on the desktop -- its the same as the "open" verb)

Michael Pryor
Tuesday, October 16, 2001

That's the question: How do I "... get Windows to work such that when you choose "Open" for an .html file on the desktop, it opens in frontpage?"

Actually, I'd rather have the option of opening the file with either the CityDesk of FrontPage editors by using "open with"

I appreciate that you have hung with me so far on this; I'm feeling dumber by the minute.  I can always paste the html back and forth between FrontPage and CityDesk if I have to.  Or, I can upgrade to Win2k (horrors) if I must.

Terry Kearns
Tuesday, October 16, 2001

Terry: follow the directions that I provided above, and you will be able to re-assign the default action for the "open" verb.

Jonathan Goodyear (aka angryCoder)
Wednesday, October 17, 2001

Thanks Johathan,

In WinExplorer using shift-rightclick on an html file lets me "Edit" which pops the file up in FrontPage just fine.  "Open" opens the file in IE.

In  CityDesk right-clicking or shift-rightclicking only gives me the opportunity to "Open With Windows Default Viewer" which is IE.  It opens the file,  "C:\WINDOWS\TEMP\CityDeskExternal_-665381\PTMFOG0000000003.html"

CityDesk does not let me "Open With Windows Default Editor" which is FrontPage.

I'm not getting anywhere.

BTW I enjoyed your "Angry Coder" site. 

Terry Kearns
Wednesday, October 17, 2001

When you "SHIFT-Right-click" your file in Windows Explorer, you aren't presented with a "Open With" option? Forget about the Edit option and the Open option. Look for "Open With" and choose FrontPage (or whatever else you want), and the click the checkbox so that html files will always open using it...This feature should be available on all Windows versions 95 and up...

BTW - Thanx for the compliments on the angryCoder.com site ;-)

Jonathan Goodyear (aka angryCoder)
Wednesday, October 17, 2001

I prefer to use vim as my HTML editor, but can't figure out how to make it work -- it's apparently not registered as an HTML editor, even though it's on the main explorer list as "Open with Vim".

Ideas?

Austin Ziegler
Thursday, October 18, 2001

I'm discovering that the whole business of how file extensions map to programs in Windows is a total mess ;)

Although your editor has taken over the "Open with Vim" verb, your "Open" item must still be bound to something else.

From an Explorer window (e.g. "My Computer"), choose Tools | Folder Options from the menu. Under "File Types", find .html.

Change the main program that is used to open this file type. The procedure for doing this depends on the version of windows that you have; in Win 2000 you have to find HTML in the list and click "Change".

When I get a chance I'll sit down with all the different versions of Windows and write up more detailed instructions for the help file.

Joel Spolsky
Friday, October 19, 2001

Michael actually provided me some instructions that worked last night -- except that it meant that I couldn't simply view HTML in IE anymore without going through contortions.

Ultimately, I think that the "editor list" will need to be configurable as much everything else is. It's not a big deal, because I can do cut and paste, but the ability to move between the two easier would be nice.

Austin Ziegler
Friday, October 19, 2001

Ditto: I prefer to view in IE, edit in Homesite but must set the latter as default viewer or suffer the extra manipulations. Not a big deal for me but I envision this program as the foundation for an intranet CM and couldn't expect the average user to jump through the hoops.

Ray Lutz
Thursday, October 25, 2001

For a (paranoid?) take on why Windows makes it hard to change your file types, read the following article on Salon...

- - - - - - - - - - - -
The devil is in Windows' details
It's the little things, like "registered file types," that allow Microsoft to maintain its monopoly. Will the court tackle them?

- - - - - - - - - - - -
By Scott Rosenberg

http://www.salon.com/tech/col/rose/2001/10/08/file_monopoly/index.html

Mark
Thursday, October 25, 2001

*  Recent Topics

*  Fog Creek Home