Fog Creek Software
Discussion Board




Knowledge Base
Documentation
Terry's Tips
Darren's Tips

Having trouble editing templates w/ external appsp

I'm looking for some help.

I'm trying to edit a template using Dreamweaver Ultradev and cannot seems to get my chages to stick.

This is what I've been doing:

1.  I right-click on a template (any template) in the Templates dialog window and choose Dreamweaver as my editor.

2.  Dreamweaver launches fine with WYSIWYG display of my template.

3.  I make some changes (even simple text and color changes), and SAVE the file.

4.  I go back to the Templates dialog box in CityDesk and click done.

5.  I then click preview from my project window and view the pages using IE.

6.  Am disappointed to see my changes are not there.

Now, I've noticed tha tDreamweaver seems to be working with a TMP version of the file and seems to be saving that TMP file when I click SAVE.

I've tried SAVE AS and am prompted by a modal dialog that I'm about to overwrite the file and I click OK.

Still no results in CityDesk.

Can someone help me here?

BTW, this is true for Dreamweaver 3 and Ultradev on a Windows 2000 box.

Thanks,
Rick

Rick Castanho
Wednesday, January 16, 2002

Try this:

Restart CityDesk
First thing -> Right click on the template and edit with DW
Save in DW
Exit DW
Hit preview in CD.

If you still get the same behaviour, then please post your machine specs (Windows Version, IE Version) or use the send feedback mechanism to send us the info (that info is included when you send feedback).

Michael H. Pryor
Wednesday, January 16, 2002

Still no luck...tried with both Dreamweaver 3.0 and Ultradev...changes don't stick.

I'm running IE5.5 on Windows 2000...

Rick

Rick Castanho
Thursday, January 17, 2002

Try this...
Quit CityDesk
Using a DOS prompt cd into your citydesk directory (\program files\citydesk)
type 'regsvr32 FCFileMonitor.dll'

Then restart CityDesk and try again.
Also try inserting a text file into CityDesk and use Notepad as the external editor and see if that makes changes stick.
And lastly, have you rebooted your machine since you started seeing this problem?

Thanks!

Michael H. Pryor
Thursday, January 17, 2002

hmmm.... i tried exiting CtyDsk and running DLL from command prompt, then resarting and running through the DE exercise...it worked!!  I successfully made a template change outside of CtyDsk in DW and it took when i previewed.  :-)

But that's where the success ended.  :-(

Subsequent changes would not stick.  Tried exiting app running DLL (lather, rinse, repeat) with no success.

Tried entire process (even rebooting machine) from beginning to end and have not been able to reproduce successful results.

BTW, text edits seem to stick fine using Notepad externally (can make edits and preview in real-time).  Nice.  'Zactly what I'm hoping to achieve with WYSIWYG HTML/Template editor.

Anyone out there successfully editing templates out side the CtyDsk world?  If so, which apps?

Thanks again.

Rick Castanho
Thursday, January 17, 2002

I edit fine in FrontPage.  You'll really like it when you finally get it to work.

TK
Thursday, January 17, 2002

Rick,

What about using the same app (dreamweaver, et al) except try it on an HTML file (not a template, but an html file in the main window)?

Michael H. Pryor
Thursday, January 17, 2002

Okay, I tried using FrontPage instead of Dreamweaver, seems to work fine editing templates and HTML file (as in index.html).

DW seems to make the changes to both templates and HTML (as in index.html) but the changes won't preview in CtyDsk...

As in...

I can open a Template (or HTML) file in DW and edit and SAVE.

Changes do NOT preview in CtyDesk.

If I then open the same template in CtyDesk Design editor, the previously made changes in DW do not show here either.

However, if I then open the template (or HTML) with Frontpage, the previously made chages made in DW show in FP.  If I SAVE from FP, the changes are then honored in CtyDsk preview and editor.

I'm finding FrontPage to not be as robust a WYSIWYG editor so I'm not giving up on a DW solution.  :-)

Thanks

Rick Castanho
Thursday, January 17, 2002

Ok, try this...

Open CityDesk
Open your template with DW
go start->search for files and look for a folder called CitydeskExternal (there should be one named CityDeskExternal_xxx where xxx is a number).
Open that external folder - this is where files get saved when you edit them with external editors. you should see an html file there which is your template file.
Keep note of the file modified time.  now go into dw make a change and save and see if the file modified time changes..

Michael H. Pryor
Thursday, January 17, 2002

Found CityDeskExternal_1852 folder and opened...

tracked HTML files mod times as i made revisions in DW - seemed to correctly revise as i went along...

Changes actually stuck in CtyDsk for a # of times while I had the folder "External" open on the desktop tracking revfsion dates.

As soon as I closed the folder and continued making revsions, changes were not sticking in CtyDsk.

Reopened "External" folder and tried again (Keeping track of revision times).  Times changes acordingly, but revisons to doc somestimes display in CtyDsk and other times not.  Seeems quite random.

:-(

Rick Castanho
Thursday, January 17, 2002

Any chance that the CityDeskExternal directory was on a remote computer (over the network?)

Michael H. Pryor
Thursday, January 17, 2002

I experienced a similar problem when i tried editing the index.html and the templates with the NAMO WebEditor 5.0
The changes did not stick.

I deleted the whole site with explorer. Quit CD. Re started. Edited an attachment with NAMO and just clicked on the save icon (NOT SAVE AS OR ANYTHING), then quit the external editor and the changes sticked.

I am a newbie at this, so.... just my own trial and error.

A E Senior
Thursday, January 17, 2002

In my previous "Edited an attachment with NAMO" instead of attachment I meant TEMPLATE.

A E Senior
Thursday, January 17, 2002

I just wanted to add that I'm using FrontPage for editing both templates and the index.html files, and it works fine each and every time. Seems Dreamweaver related to me.

Paul Iliano
Friday, January 18, 2002

Sorry, I should take back "Seems Dreamweaver related to me" since someone seems tohave the same problem with Namo. Anyway, FrontPage works fine.

Paul Iliano
Friday, January 18, 2002

I've seen this happen too, I've got Frontpage 2002 and Dreamweaver 4 UltraDev and had trouble with both. Sometimes it just seems to want to be difficult. I assumed I was me doing something stupid but if others are having the problem...

Seen with CityDesk Personal edition and Free edition - Running Windows XP Pro v.2600, IE 6 obviously(!), Dreamweaver 4 ultradev, Frontpage 2002 as part of Office XP.

Robert Moir
Friday, January 18, 2002

Is FogCreek's support going to address this issue? How do we let them know. I am also interested in a fix.

A E Senior
Monday, January 21, 2002

Hi!

Short story: yes, we will fix it in the first CityDesk service pack (around March 1).

Long story: The mechanism we're using for detecting whether a file has been edited externally is not 100% reliable. What we're going to do is modify CityDesk so every time it gets the focus (becomes the front window) it checks if you've saved the file. This should get us the 100% reliability we need. This is a priority 1 bug for us.

Thanks for bearing with us while we figure this one out!

Joel

Joel Spolsky
Tuesday, January 22, 2002

"Thanks for bearing with us while we figure this one out!"

Hey I should worry. It's annoying when it happens, but even with this, CD has made my life so much easier. So you are still in profit on the productivity karma side of things, by a long way ;-)

Robert Moir
Tuesday, January 22, 2002

I'm jumping in late here as Joel has already proposed a solution, but I can give you a related story.

We have an NT server here that we use for development. We use Dreamweaver and Homesite for HTML editing. Sometimes I need to show somebody the changes while I have them on the phone, so I edit in Dreamweaver, but then Windows shows the file as being in use, so you can't save in DW, so I (F10) view source code and copy/paste into Homesite, which can save under these circumstancse.

It seems Dreamweaver is more polite about saving than Homesite is.

Mark W
Wednesday, January 30, 2002

I have had the exact same problem with DreamWeaver.  It took me a long time to find someone else mentioning this in the discussions... but obviously I'm not alone.  And, of course Fog Creek has already said its a priority 1 bug. Yay!

Two things...

First, how about adding this bug to the Knowledge Base?  That's the first place I looked.  I'm sure Joel (who's User INterface Design for Programmers is one of the best books written on the subject) would agree that it matches the user model to look there. <poke>

The other is a work around:

I run both DreamWeaver UltraDev 4 to do my editing, and I also open the exact same file at the same time in another program (VisualStudio.NET in this case, but it could be FrontPage).  When I SAVE in DreamWeaver it seldom sticks (due to the aforementioned bug).  But VS.NET notices it when I click on VS.NET.. "Do you want to reload the file?"

"Why yes, I do!" and then FP has the current version.  I click the SAVE icon.  BOOM, CityDesk seems to always notice it when VS.NET saves and then I can preview.  When I click on DreamWeaver it says "Hey dude, want me to reload the file?" when I next give it focus.

"Why yes, I do!"  And off I go for my next round of tweeks.

This works... it's ugly and slow.  Not something a novice would ever figure out... but maybe Joel can add it as an example in his next book.... <evil grin>

By the way, the search box worked wonders to find this problem mentioned... I should have tried that first.  I didn't, of course, because SEARCH almost never finds anything useful on most web sites. <grin>  Good job!

David What;ey
Saturday, February 09, 2002

*  Recent Topics

*  Fog Creek Home