Fog Creek Software
Discussion Board




Knowledge Base
Documentation
Terry's Tips
Darren's Tips

Special caracters in placeholders

Hi,
can I place special characters in placeholders like sidebar.

I want to have a ü=ü in the sidebar. Direct use of ü doesn't work and if I use ü the ampersand is translated in html-code so that doesn't work too.

Is there another possibility?

Thank you
Markus

Markus Raabe
Wednesday, August 11, 2004

Check your charset.  This forum can show ü and uses

<META http-equiv=Content-Type content="text/html; charset=windows-1252">

Lou Franco
Wednesday, August 11, 2004

If that doesn't work, use a variable with the correct & code

Lou Franco
Wednesday, August 11, 2004

Try: <meta http-equiv="Content-Type" content="text/html; charset=utf-8"> which is what the Joel on Software site uses, and what Joel recommended when we went to CD 2.x.

David Burch
Wednesday, August 11, 2004

David's correct you've got to use the Content-Type utf-8  header. It needs to be the first thing in the <head> section of each page.

Ken McKinney
Wednesday, August 11, 2004

I had the setting for the charset included. It does work on a windows server but not on a linux server. I tried both binary and ascii transfer to the server that doesn't change.

So now I use an extra variable with the &uuml; in it and that works.

Thanks.

Markus Raabe
Thursday, August 12, 2004

You probably have to change your Apache config : AddDefaultCharset utf-8

Ronald

http://www.life4all.net

rognvaldr
Saturday, August 21, 2004

*  Recent Topics

*  Fog Creek Home