Fog Creek Software
Discussion Board




Knowledge Base
Documentation
Terry's Tips
Darren's Tips

CityDesk just won't run!!!

I'd just finished reading Joel's little blurb about the addition of exception detection and automatic sending of the error info when I downloaded the personal edition. I thought that sounded cool, but since the fog creek approach to s/w development kept any bugs from getting in the final release :), I wouldn't encounter it, right?

Well the first time I go do run CityDesk, I create a new site. It comes up with the little tree control on the left. I double-click where it says "Getting Started ... double click here". And I get the "City Desk Problem" dialog. :( I filled in a very detailed message of what I did and dutifully sent it in.

Naturally I haven't heard anything back. Now and again, I try to run it. I still get the exact same problem. The beginning of the error message is:

"V:1.0.23 Starter Edition Failed to load control 'ExtrasEditor' from . Your version of  may be outdated." Note the missing info in both of those sentences. Not sure why.

Win2K sp1

Any help would be appreciated!

Donnie Hale
Thursday, December 20, 2001

I encountered a message here from a person who had a similar problem. While upgrading IE5.5 to sp2 worked for him, it had no effect for me. I still get the error originally described.

Is a certain feature of IE required (this mythical 'ExtrasEditor')? I keep my IE install fairly lean-and-mean.

Thanks.

Donnie Hale
Thursday, December 20, 2001

Donnie,

I backed up my site as soon as I read your post.  I haven't lost a page yet but I've had a few odd problems.

I've got Win98, this list may give you some ideas until the Fog guys can get back to you.  These were instructions were suggested for getting everything up to scratch.  I haven't done it yet:

"I suggest doing the following: (please make sure you don't delete any of your .CTY files).

1. Uninstall CityDesk.

2. DO a search for "Citydesk" on your computer and make sure there are no traces left (delete all folders and  anything citydesk related EXCEPT YOUR CTY FILES -KEEP THEM!!!)

3. Search for all of these files and make sure they are  deleted (delete them if they are around):
  fcscript.dll
  fogftp.ocx
  fcsubtmr.dll
  wspell.ocx
  bugzscout.dll
  fcpopmenu.ocx
  fcvbaliml6.ocx
  fcvbaltbar.ocx
  fcpopupmenu.dll
  fcfilemonitor.dll
  fcvbalpran.dll

4. Download and install Jet 4.0 SP3 from microsoft at the following address:
http://www.microsoft.com/data/download.htm#Jet4SP3info

5. Download and install Windows Scripting 5.6 from microsoft at the
following url:
http://msdn.microsoft.com/downloads/default.asp?URL=/downloads/sample.asp?url=/msdn-files/027/001/733/msdncompositedoc.xml

6. You should update IE to sp2.  I don't know where you download the latest IE from microsot but i imagine its something like www.microsoft.com/ie

7. Download citydesk from download.fogcreek.com and install."

Paranoid TK
Thursday, December 20, 2001

Donnie -

Try this.

Look for a folder named c:\Program Files\Common Files\Microsoft Shared\Triedit

If it's there, it will have files in it named dhtmled.ocx, dtcrt.dll, and triedit.dll.

Register each of these 3 files. Here's how to register a file:
(1) Right click on it
(2) Choose  "open with..."
(3) Click "Choose program..."
(4) Click "Other"
(5) Find regsvr32.exe. It is in your Windows\System or Windows\system32 directory.
(6) Click Open.

Let me know if this fixes the problem.

Joel Spolsky
Thursday, December 20, 2001

I had also a errormessages with editing the article.
Citydesk started without any probem but as soon as I started to edit the articles or the index.htm it went wrong.

Not the same file as you got, but the same message error. That the xxxx file was outdated or not correctly registred.

I uninstalled citydesk and then reinstalled my Internet Explorer. Or did an upgrade from my 5.0 to 5.5. After that I reinstalled Citydesk and all went fine.

Mayby you want to try that.

Greetings,
Jeroen Roeterd

Jeroen Roeterd
Friday, December 21, 2001

*  Recent Topics

*  Fog Creek Home