Fog Creek Software
Discussion Board




Knowledge Base
Documentation
Terry's Tips
Darren's Tips

Big bug in template editor

I have to CD files. Both have a template called Menu.

Open CD file 1. Open CD file 2 so there are two instances.

Edit menu from file 1, now do it from file 2. File 2's menu now shows the souce form File 1. :((((((

This cost me about 5 hours last night tyring to figure out why the website was fubarred.

Chad Z. Hower aka Kudzu
Tuesday, February 10, 2004

This has happened to me. CityDesk gets confused sometimes when two instances of CityDesk are open at the same time. For me, it seems like the search gets confused about which page it's searching. It's fine sometimes but I'm in the habit of only having one CityDesk open at a time even when that's an inconvenience.

tk
Tuesday, February 10, 2004

Unfortunatel you dont always know when its acting up... and when you are copying from one to the other or comparing, you really need two instances up...

Chad Z. Hower aka Kudzu
Wednesday, February 11, 2004

It's unpredictable but it usually doesn't cause a problem.

The whole multiple instance open problem would be confusing even without this particular problem. When your in the article editor for example, you might be working on "index." Which index? If you have an "index" in each folder, which folder, which site are you editing? I'm easily confused. Worse if you have the same site open more than once.

tk
Wednesday, February 11, 2004

Sorry, but I cannot believe this.

Sometimes, I am using more then 5 CDs concurrently, havily editing articels, templates or whatever. Never had a problem with this.

However, there is an annoyingly "feature": you cannot see which dialog belongs to which CD. Even moving a dialog to a certain place does not help, since the next dialog is opened at the new position, regardless from which CD it is opened.
Are you very sure that you have not confused yourself?

Kai Jäger
Thursday, February 12, 2004

I certainly get confused and I've had multiple sites open mostly with no problem and no loss of data. But CityDesk has screwed up when I've had multiple sites open, not often though.

I don't think it's same problem but it reminds me of the unpredictable bug that can cause line feeds and carriage returns to stop working, even in the error reporting box. It rarely happens; but it happens.

tk
Thursday, February 12, 2004

*  Recent Topics

*  Fog Creek Home