Fog Creek Software
Discussion Board




Knowledge Base
Documentation
Terry's Tips
Darren's Tips

Special Charakters

I sent this topic several times to the feedback address shown in CD, but without answere.

Following happens:

If I write in normal Mode a german ü and I publish, this character is shown correctly in the browser and source-code, but if I edit this article e.g. in html mode, and I re-publish this charakter  is changed to 'ü' by CD. So a bug in CD.

Therefore the use of <META HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=iso-8859-1"> makes no difference to the result view in the browser.

Has anyone an idea?

Can maybe frogcreek fix this bug (maybe by replacing special charakters by it's enteties? e.g. ü --> &uuml;)

This is a general Problem to all german Users of CD. The same for Franse or Spain and more... they have special charakters like á ü ñ...

Thanks.

Raoul

Raoul
Tuesday, February 03, 2004

http://www.fogcreek.com/CityDesk/2.0/help/Features/UnicodeandCharacterSetIss.html what is often shown in this case doesn't work after you changed from normal to html mode...

Raoul
Tuesday, February 03, 2004

now it works...

problem was, that I haven't included the meta event first and after that CD didn't recognised, that i published the site with the meta event. I had to reedit the article and after the last publish all went good....

Raoul
Tuesday, February 03, 2004

sorry, but it's semms to work but it doesn't:

the IE shows it correct if you open the local file directly. On the webserver it looks like I wrote before.

the IE soure looks good, but If you open the file in a texteditor like ULTRA-Edit you can see, that the characters are written wrong into the file by CD.

Raoul
Tuesday, February 03, 2004

Have a look at the source code of http://www.die-steinhaeuser.de, here it all works fine in Germany! I used UTF-8 in the meta tag, you mentioned.

Give it a try and have success.

CU, Steffen

Steffen steinhäuser
Tuesday, February 03, 2004

*  Recent Topics

*  Fog Creek Home