Fog Creek Software
Discussion Board




Knowledge Base
Documentation
Terry's Tips
Darren's Tips

Character Display Help

I'm really confused about  character display in browsers and the proper charset attribute.

A little history:

1. I developed pages using the CD2 default charset=UTF-8. Ran into problems when displaying database content: accented characters in the database were replaced with ?.

2. My developer did some research and came up with charset=iso-8859-1. The characters in the database now display properly.

3. Copy-pasted some text into a CD article. Looks good in Normal view. Published and the accented characters now display really funny.

4. Went into HTML view, replaced the characters with the proper number code (&#246, for instance).  Checked in Normal view. Looks fine.

5. Published. Still funny display.

6. Checked article. Number codes replaced with accented characters in the HTML view. Put the number codes back in.

7. Published without going to Normal view. Now everything looks fine. But the article needs to be worked on in Normal view,  so the next time the characters will get messed up again.

Clearly, something's not right here, and I'm not sure where to start. Feedback, links, whatever would be greatly appreciated.

Amos
Monday, December 08, 2003

Assuming you have the header right most utf-8 problems seem to stem from misconfigured web servers. See
http://discuss.fogcreek.com/CityDesk/default.asp?cmd=show&ixPost=10165&ixReplies=9

Ken McKinney
Monday, December 08, 2003

*  Recent Topics

*  Fog Creek Home