Fog Creek Software
Discussion Board




Knowledge Base
Documentation
Terry's Tips
Darren's Tips

Unnecessary formatting in Headline & extra fields

I have the strange problem.
Text in 'headline', 'author' and some extra fields (e.g.extra1) become surrounding FONT tegs (e.g. '<p><font size=2>New page</font></p'>). I do not need this; moreover, I can not get rid of this because menu 'format' is inaccessible in window 'Properties'.
Please help.

Naivi
Sunday, November 09, 2003

How did you enter the text into those fields? Did you copy/paste it from somewhere? If so, try using Paste without Formatting. This will strip off the font tags.

David Watts
Sunday, November 09, 2003

OK, but what can I do now? If I erase 'bad' article and create new one its Magic Name will change and I will get a lot of problem...

shpolbder
Sunday, November 09, 2003

Copy the text from the extra field you are having trouble with, Ctrl-A and delete to completely remove the existing contents of that field. Then Atl-E-W (paste without formatting) the text back into the field.

tk
Sunday, November 09, 2003

I've had this in the past, where I've not been able to remove formatting and have had to go into the file using Access to remove it.

Chase
Monday, November 10, 2003

I've read here somewhere that if the formatting remains even after you delete all text, then do the following:

1. enter some junk text into the field
2. press Ctrl-A to select all
3. Delete

This supposedly deletes all the text and the formatting.

David.

David Watts
Tuesday, November 11, 2003

The formatting of the fields seems really cool when setting up a page - but contravenes a basic principle of content management which is separation of format from content.

I am using the fields as part of input for "sendmail type function" and other possible form processing. The unwanted tags are a major pain with no guarantee that content authors will "paste unformatted" or enter unformatted.

CD may need to add a construct like {$.extra1.value$} or {$.sidebar.value$} which explicitly substitutes only the text value without any tags.

In the meantime what do I do? 

How can I guarantee/prevent formatted text being entered into those fields?

Mike Osborne
Monday, November 17, 2003

*  Recent Topics

*  Fog Creek Home