Fog Creek Software
Discussion Board




Knowledge Base
Documentation
Terry's Tips
Darren's Tips

Disapearing content

I´m using the CityDesk 2.0.19.
Sometimes  when I´m editing one article changing from the HTML view to the Normal view all the content disappears.

I can´t reproduce this event. I´m trying to find exactly wath is happening.

Anyboby here have any ideas/hints?

Thanks

Camilo

Camilo Telles
Wednesday, October 15, 2003

There are several threads regarding that very topic on this board.  Just scroll down and take a look at them.

If the html code has unrecognized stuff such as javascript, or you copied/pasted your text into normal mode, this happens when you switch between normal and html modes.

To minimize this problem I do the following:

1) Templates - use an external editor if at all possible, especially if you are using javascript

2)copy and paste in HTML mode

3)if you need an article with javascript or other, you can copy and paste to and from an external editor if you do it in html mode.

4) try to avoid too much non-basic html stuff in articles.

hope that helps...
Jeff

Jeff Kolker
Wednesday, October 15, 2003

Copy and paste in HTML mode?  Thanks for the workaround but HTML mode should be there only for power users.  CityDesk's target market is the normal mode crowd and nothing you do in normal mode should result in the loss of data. 

David Burch
Thursday, October 16, 2003

That is true.  But since he was changing from html to normal mode, my suggestion would hold true. Someone has to be the developer.  And this was what my suggestion was based on.

The end user (content creator) should hopefully never need to enter HTML mode.  If they don't enter HTML mode, then the cut and paste (I think) should work.

The loss of data occurs when the user switches between modes...

Jeff Kolker
Thursday, October 16, 2003

*  Recent Topics

*  Fog Creek Home