Fog Creek Software
Discussion Board




Knowledge Base
Documentation
Terry's Tips
Darren's Tips

Copy Paste problem

I'm having real problems with copy / paste, and wondering if others have run into the same problem.

I've opened two instances of CD. In one is the old site, in the other is the new site. I want to copy the contents of an article from the old site to a new article in the new site.

I open the old article in Normal view. Select All, then Copy, then Save and Close. I open the new article in Normal view. Select All, then Paste. (Select All just to be safe). After going to the Properties tab to change the headline and come back to Normal, most of the text is gone. Same happens if I Paste, then Save and Close and open the article again.

If I copy the HTML View and paste to the HTML View, the text stays.

Strangest behavior, both on my desktop at work and laptop at home. On both I'm running Windows 2000 Pro and CD2.

Amos
Tuesday, October 14, 2003

According to the help file, you're supposed to use "Edit -> Copy" in the source City Desk, and then switch to the target City Desk and use "Edit -> Paste".

I haven't tried this, though . . . yet.  But the help file suggests this is the proper way to do this.

Kevin
Tuesday, October 14, 2003

Amos :re Copy/Paste

Yes, I can confirm that what you're seeing is exactly what I have been experiencing as well.

What is interesting is trying to reproduce this behavior -- sometimes I can an other times I can't which is why I have not reported this issue as a problem.

If I copy in HTML view and Paste in HTML view -- never going into normal view -- the paste sticks; however, switching to normal view is where the intermittent anomalies occur in haphazard fashion. I suspect that the Access BLOB is not as stable as it should be under CityDesk.

David Mozer
Tuesday, October 14, 2003

I suspect that the normal view WYSISYG cut/copy and paste operation is not grabbing and or putting all (if any) of the htlm code used to define the page.  And because of this, errant html code, including your text, is being deleted when you return to the normal window. 

However, in html view all the code is displayed as text so everything is acted on.

I've tried copying from normal mode to an external editor's layout mode and it has never worked. 

I've just learned to 1) use my external editor whenever possible and 2) copy in html mode only.

If you highlight want you want to copy in normal mode, then switch to html mode, you will see the related code highlighted.  Sometimes you have to adjust for certain things, but at least it puts you in the right area for html cutting and pasting.

hope this helps some....

Jeff Kolker
Tuesday, October 14, 2003

What I believe would be appropriate under circumstances where one switches between Normal View and HTML View is to have CityDesk provide an error trap showing the offending HTML segments that cause the pasted text from being displayed/evicted  in WYSIWYG view [Normal View]. To have the pasted text simply disappear [when switching views] is not a good thing.

However, I fully understand that end-users who work in Normal View do not have issues -- outside of the fact that currently normal view is somewhat lacking in formatting features [i.e style] like that found in MS Word. IMO normal view does exactly what the author intended and for the *less demanding* end-users works well.

At the same time, however, since CityDesk is also a Developers Tool [ala Designer mode] the developer *needs* to have effective feedback -- meaningful error traps; [1] between HTML view and Normal view [2] FTP logs [3] run-time debugger.

David Mozer
Wednesday, October 15, 2003

Right now I'm doing some pasting from one site to another with tow .cty files open at once.

I'm pasting article HTML. I've noticed that when I close the article I'm pasting from, I get the "do you want to save changes" message even though I have made no changes. City seems to get a little mixed up when two sites are open.

tk
Thursday, October 16, 2003

When you use the "Remove Formatting" menu option, it never removes the very first formatting tag - I always have to go into HTML and remove that tag.

I usually notice this when I've got a bullet list in word, copy and paste into CD (forgetting to use the paste without formatting feature), so I highlight the list of items in CD and hit Remove Formatting and I have a bunch of hieroglyphs because in the HTML I'm left with at the start:

<span lang="EN-US" style="FONT-SIZE: 7pt; FONT-FAMILY: Wingdings; mso-ansi-language: EN-US; mso-bidi-font-size: 12.0pt; mso-bidi-font-family: Tahoma" xml:lang="EN-US">

Funny.

Dan
Monday, November 03, 2003

*  Recent Topics

*  Fog Creek Home